No content in this loop



Everything is working swimingly with the shortcode and posting topics but none of the URLS work to the actual post. Gives me the classic no content in this loop. Any thoughts?

  • Hi

    I'm wondering if that might be related to your theme. Could you try a quick test and switch to a default theme like Twenty Sixteen? I think the content will appear.

    If so, email us a copy of the theme and we'll take a look.

    • Thanks. I actually just turned permalinks on and off quick and it worked! The issue I have now is that the post does NOT have the reply information below the post.
      I have the Allow people to post comments on new articles checked in the general Discussion area. What am I doing wrong to see the response? Thanks for the quick shout back

    • I have Admin and Subscribers able to post and registering new users as Subscribers. I am not seeing the ability to reply on a general post on the site as well. Could someone have turned off the reply somehow? I just took the site over so don't know the full build!

  • Okay. It's probably easier if I can take a look at the admin. Could you email temporary access to me at info[at]



  • I am using Discussion Board Pro 1.5.0 with Wordpress 4.7. I have tried to use several themes including Twenty Fifteen, Twenty Sixteen and Twenty Seventeen, Make (with Make Plus) which I prefer for its editing and customizing capabilities. However, none seem to solve my problem.

    My Admin account (after logging into the Discussion Board) can only access the Discussions page, and after opening a discussion, I cannot post on the page. On the Discussion Board page and the Discussion Topic page, I receive the following:

    You're not currently permitted to view this content. Please log-in or register in order to view the page.

    When I log in using another account, I have full access to everything once logged in.

    Any suggestions?

    Bill Hood

  • Just to close this thread: the issue with not being permitted to access content was solved by setting 'Permitted viewer roles' to empty - i.e. allowing all roles to view content:

Comments are closed.